www.i4info.org

i4info Provides the best hacking Material. Latest hacking tutorials and tools are available here. It is the best place for hackers.

Latest topics

» Facebook Account Hacked
Today at 10:14 am by ssameer758

» Teen Patti Gold Hack & 3 Patti Chips Code Extra Bonus 2016
Today at 8:31 am by furqansweet73

» BitCoin Wallet stealor New
Wed Dec 07, 2016 7:46 pm by Admin

» Muhammad Shahroze Rashid | Marketing Consultant
Wed Dec 07, 2016 1:48 pm by Admin

» Muhammad Shahroze Rashid | Sharp Mind, Sharp Innovations
Wed Dec 07, 2016 1:47 pm by Admin

» How to design an effective job ad
Wed Dec 07, 2016 1:45 pm by Admin

» Content Marketing | Promotional Video
Fri Dec 02, 2016 2:45 pm by Admin

» How to start an Online Business | Complete Guide
Fri Dec 02, 2016 2:30 pm by Admin

» Zeeshan Bhatti
Wed Nov 30, 2016 3:18 pm by Admin

December 2016

MonTueWedThuFriSatSun
   1234
567891011
12131415161718
19202122232425
262728293031 

Calendar Calendar

Affiliates


free forum

Forumotion on Facebook Forumotion on Twitter Forumotion on YouTubeForumotion on Google+

Visitors Counter


Flag Counter

About Author

Muhammad Shahroze Rashid
i4info
Web Developer
Web Developer & Designer,Researcher and Technical writer. An Information Security Consultant and System Auditor, a keen Security researcher.
samanabad
lahore, Punjab
54000
Pakistan
[email protected]
03064904829
DOB: 05/25/1992
Muhammad Shahroze Rashid
Muhammad Shahroze Rashid is a Web Developer and Designer, Android Developer, InfoGrapher, IT consultant and Researcher
Reviewed by Google
Google
Date published: 01/19/2016
9 / 10 stars
Muhammad Shahroze Rashid
Muhammad Shahroze Rashid Web Developer & Designer,Researcher and Technical writer. An Information Security Consultant and System Audito
samanabad
lahore
Punjab
54000
Pakistan

Make your own VPN

Share

Admin
Admin

Posts : 455
Reputation : 5
Join date : 2014-12-10
Age : 24
Location : Pakistan

Make your own VPN

Post by Admin on Sat Feb 14, 2015 10:23 am

I will tell you How you can make your own VPN (Virtual Private Network) between your Home Router and Office Router.

For this me use Cisco 3700 router.

Router R1 works as Home Router and R3 works as Office Router and between R1 and R3 we will use router R2 as Internet Router. You can see full diagram in below picture....


Now me going to given IP address to all router interface. For Router R1 interface f0/0 , i use IP add 172.16.12.1 /24 and for Router R2 interface f0/0 172.16.12.2 /24 and same for interface f0/1 172.16.23.2 /24 , and in last for router R3 interface f0/1 me use 172.16.23.3 /24.

And also make Loopback 1 in Router R1 and R2. For Router R1 loopback is 1.1.1.1 /24 and for R3 is 3.3.3.3 /24 .

First question here is why i am using IP add 172.16.0.0 where this is came into private IP address range, because i am using this only for example, you may take it and else as your wish.

Now for live example see below three picture for above work....




Now i am going to given static IP route for communicate the Router. You may run any interior protocol rather static route.Now see below two pic for static ip route in router R1 and R2....





Now i am going to Ping IP add of R3 by R1 , when you ping it then it successfully ping but when you ping by source Loopback then you get success rate 0.See below two pic for see Ping router R1 to R3 and R3 to R1...




So now me going to make VPN here. First know it, work of building VPN divided into two phase>> Phase 1 & 2.
Now make access-list on router R1 and run command:



R1(config)#access-list 110 permit ip host 1.1.1.1 host 3.3.3.3
R1(config)#crypto isakmp policy 10
R1(config-isakmp)#authentication pre-share
R1(config-isakmp)#encryption 3des
R1(config-isakmp)#group 2
R1(config-isakmp)#hash md5
R1(config-isakmp)#exit
R1(config)#crypto isakmp key 6 cisco address 172.16.23.3
R1(config)#crypto ipsec transform-set esp-3des esp-md5-hmac
exit
R1(config)#crypto map mymap 10 ipsec-isakmp
R1(config-crypto-map)#match add 110
R1(config-crypto-map)#set transform-set tset
R1(config-crypto-map)#set peer 172.16.23.3
exit
R1(config)#int f0/0
R1(config)#crypto map mymap



when you did all steps on R1 then it show you a msg like "isakmp is on" See below two pics for R1 full configuration....



Now Run same command with some changes in router R3:


R1(config)#access-list 115 permit ip host 3.3.3.3 host 1.1.1.1
R1(config)#crypto isakmp policy 15
R1(config-isakmp)#authentication pre-share
R1(config-isakmp)#encryption 3des
R1(config-isakmp)#group 2
R1(config-isakmp)#hash md5
R1(config-isakmp)#exit
R1(config)#crypto isakmp key 6 cisco address 172.16.12.1
R1(config)#crypto ipsec transform-set esp-3des esp-md5-hmac
exit
R1(config)#crypto map mymap 15 ipsec-isakmp
R1(config-crypto-map)#match add 115
R1(config-crypto-map)#set transform-set tset
R1(config-crypto-map)#set peer 172.16.12.1
exit
R1(config)#int f0/1
R1(config)#crypto map mymap


See below pic for full configuration:

Now go to R1 and Ping 3.3.3.3 by source 1.1.1.1 , now it ping successfully.see below pic...


Now go to R3 and Ping 1.1.1.1 by Source 3.3.3.3 , it ping now successfully:see below pic...


Now your VPN working successfully. Both Loopback ping whose that did not ping before. For check status run command " sh crypto isakmp sa " , see below pic, it showing you idle state.



    Current date/time is Sun Dec 11, 2016 2:44 pm